I was disappointed when I discovered that the very handy heroku db:pull stop working for me after upgrading to Ruby 2.0 and Rails 4.0.

I got it going again – by basically reverting back to Ruby 1.9.3 and Rails 3.1.0.

Here are the steps on how to revert back with rvm.

$ rvm install 1.9.3
$ ruby -v
$ rvm use 1.9.3-p286
$ rvm gemset create rails310
$ rvm 1.9.3-p286@rails310
$ rails -v
$ gem install rails -v 3.1.0
$ rvm gemset list
$ heroku db:pull –app targetapp
$ gem install taps
$ gem install sqlite3
$ heroku db:pull –app targetapp

Voila! Done.

Advertisements