Apple has a thing where they like your app to tell them what services, if any, are required.

They do this by tracking meta data in what are known as plists. A dictionary of configuration items for your app.

My app needs location services. So it wouldn’t make sense for any devices to download my app if they don’t support location services.

The way I tel my app that location services are required is to open my plist file:

and then go to the ‘Required Device Capabilities’ section and add ‘location-services’.

Note – this is a human readable for of what gets stored in the actually plist file. To see the actual property name hold down control and click on item and select the ‘Show Raw Key Values’ option.

Then you will see the actual underlying property configuration name.

Advertisements